Temporary login page outage
Incident Report for Applicant Tracking Software
Resolved
All impacted services have recovered and are available. This issue has been resolved.
Posted 11 months ago. Aug 10, 2018 - 16:14 PDT
Identified
The issue has been identified and a fix should be live shortly.
Posted 11 months ago. Aug 10, 2018 - 15:59 PDT