Applicant Notes May Be Missing In Applicant Profiles
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 17:05 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 24, 2020 - 15:13 PST
Identified
Some users may encounter a blank notes section in applicant profiles, we are aware of this issue and looking to resolve it. We sincerely apologize for any inconvenience this has caused.
Posted Feb 24, 2020 - 15:13 PST