Some Clients May Be Experiencing Issues with Onboarding Templates
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 17:36 PDT
Identified
This issue has been identified and we are working on the fix.
Posted Sep 02, 2020 - 15:56 PDT
This incident affected: Offer letters.