Some users may be encountering error messages when attempting to make changes within their ATS account.
Incident Report for Applicant Tracking Software
Resolved
The fix for this incident has been deployed and all components are operational at this time. We apologize for any inconvenience that this has caused you and your teams.
Posted May 17, 2022 - 12:53 PDT
Identified
Our team has identified the issue and working to release a fix as soon as possible.
Posted May 17, 2022 - 12:42 PDT
Investigating
Some users may be encountering error messages when attempting to make changes to jobs or account details. Our team has identified the issue and working to release a fix as soon as possible.
Posted May 17, 2022 - 12:36 PDT
This incident affected: Application Viewer.