Offer Letter and Send Documents Delay
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Oct 10, 2020 - 10:12 PDT
Monitoring
Performance improvements are in place, monitoring continues.
Posted Oct 09, 2020 - 15:02 PDT
Identified
Our third party e-signature provider is experiencing delays in document and signature actions. They have identified the issue and are working on a resolution.
Posted Oct 09, 2020 - 08:12 PDT
This incident affected: Offer letters.