The ATS platform is currently unavailable
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved. The platform is back online.
Posted Jan 10, 2022 - 10:13 PST
Investigating
We are currently investigating this issue.
Posted Jan 10, 2022 - 10:06 PST
This incident affected: Careers page, Offer letters, Message templates, Form builder, Background checks, Account Login, Applications, and Calendaring.