Some Users May Notice a Temporary Issue with Form Builder
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 10:32 PDT
Investigating
Some users may notice that they cannot currently reorganize their questions in the Form Builder section of a job. This issue is currently being investigated and should be fixed shortly. All other aspects of Form Builder are currently operational.
Posted Sep 16, 2021 - 10:26 PDT