Some users may not be able to edit or delete reviews
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved. If you are still experiencing this issue, please clear your cache and cookies before trying again. Feel free to reach out to the Support Team if the issue persists.
Posted Mar 05, 2024 - 14:00 PST
Update
Our engineering team is still actively working on resolving the issues with editing and deleting reviews. Thank you for your continued patience and understanding.
Posted Mar 05, 2024 - 06:28 PST
Update
Our engineering experts continue to dedicate their efforts toward a solution. We sincerely appreciate your ongoing patience and support.
Posted Mar 04, 2024 - 09:24 PST
Update
Our team continues to work towards a solution for the issue preventing editing and deleting candidate reviews. We apologize for any inconvenience that this may cause.
Posted Mar 01, 2024 - 12:05 PST
Update
We are continuing to work on a solution for the issues related to editing and deleting reviews. Our team is dedicated to resolving this as quickly as possible. Thank you for your continued patience and understanding.
Posted Feb 28, 2024 - 13:36 PST
Update
Our engineering team is still actively working on resolving the issues with editing and deleting reviews. Please be assured that we are making every effort to ensure the review feature operates at its best. Your patience and understanding as we work through this are greatly appreciated.
Posted Feb 27, 2024 - 10:02 PST
Update
Our engineering team is actively working on a fix for editing and deleting reviews. Rest assured, we are working diligently to restore the functionality of the reviews feature to its optimal state. We appreciate your patience and understanding during this process.
Posted Feb 24, 2024 - 11:18 PST
Identified
Our engineering experts have identified the issue affecting reviews and are diligently working on a solution. Stay tuned for the anticipated return of a seamlessly functioning review feature. Your patience and support are greatly appreciated
Posted Feb 23, 2024 - 13:29 PST
This incident affected: Application Viewer.