Inability to add new users has been reported by some users
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved. Thank you for your patience!
Posted 11 months ago. Aug 29, 2018 - 12:59 PDT
Investigating
Some users have reported that they are unable to add new users. We are looking in to the issue and will provide updates as soon as we have them.
Posted 11 months ago. Aug 29, 2018 - 11:08 PDT