Some users may observe "Active Paid Postings" without available job board details.
Incident Report for Applicant Tracking Software
Resolved
This issue has been resolved, and we're back on track! Your seamless experience is our top priority. Should you have any lingering concerns or need assistance, our support team is here for you. Thank you for your patience and understanding!
Posted Dec 07, 2023 - 11:04 PST
Identified
Some users may observe "Active Paid Postings" without available job board details. Please be assured that your previously selected job board ads are active. Our team is actively working to restore visibility into job board history details. We appreciate your patience as we resolve this issue. Rest assured, your active job board postings remain operational. Thank you for your understanding!
Posted Dec 06, 2023 - 11:27 PST
This incident affected: Job Board Distribution.