Some Users May Not be Able to Edit Job Templates

Incident Report for Applicant Tracking Software

Resolved

The issue impacting the Edit button on Job Description Templates has been resolved. Users should now be able to edit templates without being redirected to the Account Details page.

In some cases, you may need to clear your browser’s cache and cookies for the fix to take effect.

Thank you for your patience while our team worked to restore normal functionality.
Posted Sep 22, 2025 - 11:43 PDT

Investigating

We're currently in the midst of investigating an issue with Job Description Templates. Our dedicated team is on the case, diligently searching for the root cause.

Here's what we know so far:
Clicking the Edit button on a Job Description Template redirects users back to the top of the Account Details page instead of opening the editor

In the meantime, please:
Refresh your Applicant Tracking System page periodically to see if the issue has been resolved.

Your understanding and patience are greatly appreciated as we work to ensure the smooth operation of Job Description Templates.
Posted Sep 22, 2025 - 10:51 PDT
This incident affected: Create/Edit Jobs.