Some Users May be Experiencing Delays with Account Access

Incident Report for Applicant Tracking Software

Resolved

This incident has been resolved.
Posted Jul 29, 2024 - 10:00 PDT

Investigating

Our Applicant Tracking System has encountered a temporary technical issue, causing some user account access delays. We understand the importance of timely resolution and sincerely apologize for any inconvenience this may cause.

Our team of tech wizards is diligently investigating the issue and working tirelessly to resolve it promptly. We appreciate your patience and understanding as we navigate this technical challenge.
Posted Jul 29, 2024 - 09:40 PDT
This incident affected: Account Access.