Some users may experience issues with offer letters and documents.
Incident Report for Applicant Tracking Software
Resolved
HelloSign operations have returned to normal. Offer Letters and Onboarding Documents are now fully functional. Applicants who encountered an error attempting to complete or sign an offer letter or onboarding document are now able to retry.
Posted Sep 29, 2020 - 05:17 PDT
Investigating
HelloSign is entering into a maintenance period and will be down temporarily.
Posted Sep 28, 2020 - 16:33 PDT
Identified
HelloSign has identified a cause and a fix is being rolled out.
Posted Sep 28, 2020 - 15:43 PDT
Investigating
HelloSign is currently investigating slowness which may be impacting users attempting to add onboarding documents or use the Send Documents feature. Any applicant attempting to sign a document or offer letter will see an error. Once resolved, however, applicants will be able to re-sign.
Posted Sep 28, 2020 - 14:23 PDT
This incident affected: Offer Letters.