Some Services May Be Temporarily Affected by Cloud Provider Issue

Incident Report for Applicant Tracking Software

Postmortem

Summary 

 On October 20, 2025, portions of the ATS platform experienced intermittent instability as a result of the Amazon Web Services outage affecting one of our infrastructure providers. While the ATS remained generally operational throughout the incident, some background integrations and related services were temporarily degraded. 

Impact 

Most users were able to access and use the ATS web app and APIs during this event. However, some customers may have noticed occasional delays or minor interruptions in background processes, search indexing, or scheduled jobs. A small number of integrations experienced brief instability as connected services encountered related outages. 

Resolution 

Our team monitored the situation closely and confirmed that once our infrastructure provider resolved the underlying issue, ATS operations stabilized without requiring manual intervention. Any delayed background tasks were automatically retried and completed successfully. 

Next Steps 

We are continuing to review alerting and monitoring systems to improve response visibility during upstream service incidents.

Posted Oct 23, 2025 - 08:01 PDT

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:54 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:25 PDT

Investigating

We’re currently looking into problems impacting some of our cloud-hosted services. During this period, users might notice slower performance or temporary service disruptions. Our team is in close contact with our cloud provider as we work to pinpoint the issue and bring all services back to normal. We’ll share more updates as soon as we have additional details.
Posted Oct 20, 2025 - 06:56 PDT
This incident affected: Third Party Services.