Some users may experience delays

Incident Report for Applicant Tracking Software

Resolved

This incident has been resolved. Background job processing, including background check orders, report generation, and outgoing messages, is back to normal speed and any delayed items have been fully caught up.

Thanks for your patience while we worked through this — let us know if you spot anything that still looks off.
Posted Sep 01, 2026 - 13:01 PDT

Identified

We've identified a bottleneck affecting the speed of processing across the platform. This is causing delays in several areas, including background check orders, report generation, and outgoing messages.

Time-sensitive actions like password resets are not affected and are processing normally.

Our team is actively working to add capacity and clear the backlog. We're sorry for the inconvenience this may cause and appreciate your patience while we get things back up to speed.
Posted Sep 01, 2026 - 10:16 PDT
This incident affected: Background/Drug Screening, Bulk Actions, Messages, Offer Letters, and Reports.