Users adding events to multiple calendars may see duplicate calendar entries
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 12:57 PST
Investigating
Our engineering team is investigating this issue with our third-party calendaring provider Cronofy.
Posted Dec 15, 2021 - 08:38 PST
This incident affected: Calendaring.