Degraded performance with sending/receiving offer letters and documents.
Incident Report for Applicant Tracking Software
Resolved
HelloSign has resolved this incident and our engineering team has ensured that all offers and e-sign documents initiated through our platform have been resent.
Posted Dec 13, 2021 - 12:00 PST
Monitoring
HelloSign has posted the following update: We have left emergency maintenance mode and apologize for how long that took. We are continuing to monitor our systems to make sure they are performing to expectation.
Posted Dec 13, 2021 - 10:59 PST
Identified
HelloSign has identified the issue and are working to resolve it.
Posted Dec 13, 2021 - 07:48 PST
Investigating
Our third-party e-sign provider HelloSign has reported degraded performance. They are currently investigating the issue.
Posted Dec 13, 2021 - 07:03 PST
This incident affected: Offer Letters.