Some Users May be Experiencing Delays
Incident Report for Applicant Tracking Software
Postmortem

Summary

On 11/5/2024, between 9:40 am and 10:30 am PT, our Applicant Tracking System (ATS) experienced a minor slowdown in processing certain types of activities, such as parsing new resumes, sending interview requests, and certain types of manager notifications. 

Customer Impact

Some customers may have seen a delayed processing time during that brief window for activities such as parsing new resumes, sending interview requests, and certain types of manager notifications. 

What Happened

We experienced an unexpected surge in system usage during that timeframe. 

Our Response and Resolution

Our engineering team responded swiftly by increasing server capacity to expedite processing times, allowing us to restore normal operation in under an hour.

Future Improvements

We’re already midway through implementing a more advanced system for processing user hiring activities more expediently. 

We apologize for any inconvenience this may have caused and thank you for your continued trust in our ATS. We’re dedicated to improving our systems to provide a seamless experience for all our users.

Posted Nov 07, 2024 - 13:29 PST

Resolved
We’re pleased to share that a fix has been successfully implemented and monitored, and it’s now holding steady in the code. Our tech team is confident that the system is functioning as expected once again.

If you continue to experience any delays, please try clearing your cache and cookies before contacting support. This step will help ensure you’re accessing the most current version of the Applicant Tracking System.

We apologize for any inconvenience this issue may have caused and appreciate your patience and understanding as we worked to resolve it. Thank you for sticking with us!
Posted Nov 05, 2024 - 10:37 PST
Identified
We’re currently experiencing a temporary technical issue that may cause a slight delay in completing some tasks. We know how important it is for the system to run quickly and efficiently, and we apologize for any inconvenience this may bring.

What’s happening: The system is experiencing minor delays so some tasks that would normally take under a minute are taking closer to 20 minutes for the system to complete.
What we’re doing: Our tech team is actively working to resolve the issue as quickly as possible.
When should the issue be resolved: We expect to be caught up within two hours.
What you can do: Take a moment to relax while the system catches back up. We’re fully focused on getting things back to normal.

We’ll keep you posted with any updates as we work to restore the Applicant Tracking System to full speed. Thank you for your patience and trust in us!
Posted Nov 05, 2024 - 10:19 PST
This incident affected: Account Details, Application Viewer, Background/Drug Screening, Calendar, Careers Page, Create/Edit Jobs, Help, Job Board Distribution, Messages, Offer Letters, Reports, and Third Party Integrations.