Indeed Visibility Limited
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 14:05 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2020 - 11:00 PDT
Investigating
Some clients may experience a delay with their jobs being visible on Indeed or may experience a longer than usual delay with their jobs appear on Indeed. We sincerely apologize for any inconvenience this has caused.
Posted Sep 28, 2020 - 10:34 PDT
This incident affected: Careers page.