Some Users May Experience Delays with LinkedIn Limited Postings
Incident Report for Applicant Tracking Software
Resolved
LinkedIn has updated us and this issue has been resolved.
Posted May 04, 2021 - 10:45 PDT
Investigating
LinkedIn has reported delays in posting new jobs for LinkedIn Limited Listings. Some users may experience delays in their jobs appearing on LinkedIn's website. At this time, they have not provided an ETA on a resolution for this issue. We will continue to update as we receive updates from them. We apologize for any inconvenience this may cause.
Posted Apr 30, 2021 - 13:22 PDT