Log In Issues
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 18:24 PST
Update
We are continuing to monitor for any further issues.
Posted Mar 01, 2021 - 14:39 PST
Monitoring
Some users may experience issues logging into the system and come across a maintenance page. We're Monitoring the situation. We sincerely apologize to those of you who are impacted.
Posted Mar 01, 2021 - 14:39 PST