Manage Users Page - Users List Not Visible
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 09:10 PST
Investigating
We are investigating availability issues with the users list in the Manage Users page. Further updates will be provided as the investigation continues/is resolved.
Posted Nov 05, 2019 - 08:05 PST