The issue affecting the Manage Users page within Account Details—including problems with adding, deleting, and assigning users—has been fully resolved.
All related functionality, including Site and Job assignments, should now be operating as expected. If you continue to experience any unusual behavior, please refresh your browser and try again. Don’t hesitate to reach out to Support if further assistance is needed.
Thank you for your patience while we worked to restore full functionality.
Posted Jul 18, 2025 - 11:03 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 17, 2025 - 20:03 PDT
Identified
We’ve identified the root cause of the issue affecting the Manage Users page within Account Details, and one of our engineers is actively working on a fix.
We’ve also confirmed that this issue is impacting Site and Job assignments for some accounts.
While the fix is in progress, the issue may continue to affect some users into next week. We are currently targeting a resolution by mid-week.
Temporary Workarounds - If you receive an error stating that a user already exists when trying to re-add them, and your email domain supports it, you can use email plus addressing (e.g., username+1@yourdomain.com) to create a unique variation.
- If you are unable to delete a user who should no longer have access, you can edit their email address to a non-existent one to prevent login.
- If you're unable to assign a hiring manager to a site via the Manage Users page, you can edit the specific job posting and assign them as a hiring manager directly on the job.
We’ll continue to share updates here as progress is made. Thank you for your continued patience and understanding.
Posted Jul 17, 2025 - 08:29 PDT
Update
Our team is continuing to investigate the issue affecting the Manage Users page. While we don’t have new information to share at this time, please know that resolving this remains a top priority. We’ll provide further updates as soon as we have more to report.
Thank you for your continued patience.
Posted Jul 16, 2025 - 15:22 PDT
Investigating
We are currently investigating a technical issue impacting the Manage Users page in Account Details. Our engineering team is actively working to identify the root cause and implement a solution.
Currently: - Some users are unable to delete other users, even with the correct permissions. - Attempts to re-add a previously deleted user may result in an error stating that the user already exists. - Impact varies depending on how users access the Applicant Tracking System (ATS).
Temporary Workarounds: - If you encounter the “user already exists” message when adding a user, and your email provider supports it, use email plus addressing (e.g., username+1@yourdomain.com) to create a unique email variation. - If you're unable to delete a user who should no longer have access, you can temporarily edit their email address to a non-existent one to prevent login.
We recommend refreshing your ATS page periodically to check for updates as we work toward a resolution.
Thank you for your patience and understanding while we address this issue.
Posted Jul 16, 2025 - 10:40 PDT
This incident affected: Account Access and Account Details.