Some users may experience issues with offer letters and documents
Incident Report for Applicant Tracking Software
Resolved
HelloSign has resolved the incident and all systems are now operational.
Posted Nov 17, 2020 - 16:15 PST
Investigating
HelloSign is experiencing responsiveness issues. Fixing this issue is taking longer than they originally expected. Their engineers are working on the problem and HelloSign should be back up soon.
Posted Nov 17, 2020 - 14:01 PST
This incident affected: Offer letters.