Error 500 when signing/creating onboarding documents
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 19 days ago. Jul 02, 2019 - 12:30 PDT
Investigating
We are currently experience a failure in signing documents as well as the creation of signature requests that may result in Error 500. We are aware of the issue and it is being looked into at this time.
Posted 19 days ago. Jul 02, 2019 - 12:25 PDT
This incident affected: Offer letters.