Some Users May Experience Issues When Trying To Bulk Update Applicants

Incident Report for Applicant Tracking Software

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 04, 2025 - 07:53 PST

Investigating

Some users may be experiencing issues when attempting to use the "Update Applicant" option within bulk actions on the applicant grid. Our team is currently investigating the cause and will provide updates as more information becomes available. Thank you for your patience.
Posted Dec 03, 2025 - 10:39 PST
This incident affects: Bulk Actions.