Error sending onboarding docs with an offer letter
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 13 days ago. Aug 06, 2019 - 10:35 PDT
Investigating
Some users may see the following error message when attempting to send onboarding docs with an offer letter: "Oops! Something went wrong." We are currently investigating.
Posted 13 days ago. Aug 06, 2019 - 08:55 PDT
This incident affected: Offer letters.