Some Users May Notice Approval Rejections Not Updating Correctly

Incident Report for Applicant Tracking Software

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 11:07 PDT

Update

We're still actively investigating this issue. We'll provide another update as soon as we have more information to share.
Posted Apr 13, 2026 - 04:49 PDT

Investigating

We are currently investigating an issue with the approval workflow. When an approver rejects an offer letter or job requisition, the rejection is not communicated back to the original requester. Instead, the request continues to appear as “pending approval” in the system.

We apologize for any inconvenience this issue may cause and appreciate your patience as we work to resolve it.
Posted Apr 10, 2026 - 05:10 PDT
This incident affected: Workflows.