Some Users May See An Error When Using Reply in Applicant Messaging

Incident Report for Applicant Tracking Software

Postmortem

On Wednesday, 4/22/2026, some users experienced an unexpected error when reopening the mailbox after switching between applicants. Our team identified the root cause quickly: the mailbox was attempting to reload the previously viewed message from a prior applicant instead of the current applicant.

We're pleased to share that the issue has been identified and a fix was released. No data was lost or compromised — this was purely a navigational state issue affecting the viewing experience.

Thank you for your continued support!

Posted Apr 23, 2026 - 07:06 PDT

Resolved

This incident has been resolved. The Reply option in applicant messaging is fully operational.

The fix has been confirmed and users can now navigate between applicants and use the Reply option without encountering an error or page freeze. No further action is needed on your end.

We sincerely apologize for the disruption this caused to your workflow and appreciate your patience while our team worked to get things back on track. If you experience any further issues, please don't hesitate to reach out to our support team.
Posted Apr 22, 2026 - 15:03 PDT

Monitoring

A fix has been deployed for the error occurring when using the Reply option in applicant messaging.

We are actively monitoring the platform to confirm the issue has been fully resolved. If you were affected, you should now be able to navigate between applicants and use the Reply option without encountering an error.

If you're still experiencing any trouble, try clearing your cache and cookies and give it another go. Please reach out to our support team if the issue persists and we'll be happy to help.
Posted Apr 22, 2026 - 13:23 PDT

Identified

We have identified the cause of the error occurring when using the Reply option in applicant messaging.

When navigating between applicants after viewing a message thread, the system was attempting to reload the previously viewed message for the new applicant — causing an error and, in some cases, freezing the page entirely. Our team has identified the root cause and a fix is actively in progress.

In the meantime, performing a full page reload between applicants will allow you to continue working. We apologize for the disruption and will share another update as soon as the fix is deployed.
Posted Apr 22, 2026 - 11:16 PDT
This incident affected: Messages.