Some Users May Experience Issues When Saving Changes Made to Form Builder Questions
Incident Report for Applicant Tracking Software
Postmortem

Incident Summary:
From July 15, 2024, to July 17, 2024, we observed an issue affecting the form builder feature on the create/edit job page. Some users encountered difficulties when attempting to save changes made to form builder questions, leading to an inability to finalize their forms.

Customer Impact:
Clients reported being unable to edit and save changes to their form builder questions. Users experienced the system getting stuck once attempting to click on the "save" button and the changes were not applied.

Root Cause:
The issue was traced to a front-end bug in the form builder feature. Specifically, tag handling, invoked when the save button was clicked, was not executing properly. We confirmed that the problem wasn't with our servers or data storage (the backend) but solely with how the form worked on users' screens.

Resolution Steps:
Our team successfully implemented a solution to resolve the immediate issue, restoring the form builder functionality. We are also making plans to enhance this feature further to ensure more robust performance and reliability in the future.

If you have any further questions or concerns, please do not hesitate to reach out to our support team.

Posted Jul 22, 2024 - 20:26 PDT

Resolved
Our team has successfully implemented a solution to resolve the issue impacting the form builder feature on the create/edit job page. Users should now be able to save changes made to form builder questions without any problems. We apologize for any inconvenience this may have caused and appreciate your understanding and patience as we worked to resolve this issue. If you continue to experience any problems, please reach out to our support team.
Posted Jul 17, 2024 - 07:51 PDT
Identified
Our team has identified the cause of the issue impacting the form builder feature on the create/edit job page for some users. This is a high-priority concern for us, and we are actively working on implementing a solution. We are dedicating all necessary resources to resolve this issue and restore functionality as quickly as possible. We appreciate your understanding and patience during this time.
Posted Jul 16, 2024 - 14:38 PDT
Investigating
We're currently investigating an issue with the form builder feature on the create/edit job page. Some users are experiencing problems when attempting to save changes made to form builder questions. Our team is working diligently to identify the root cause. We appreciate your understanding and patience as we address this issue.
Posted Jul 15, 2024 - 13:23 PDT
This incident affected: Create/Edit Jobs.