Some Users May Have Experienced Issues with Applicant Viewer and Application Settings

Incident Report for Applicant Tracking Software

Resolved

These issues have now been resolved, and everything should be functioning as expected. Thank you for your patience and understanding as we worked through these concerns. If you encounter any further issues, please don’t hesitate to reach out to our support team for assistance.
Posted Jan 28, 2025 - 18:44 PST

Monitoring

We are aware of multiple issues related to applicant viewing, including requiring applicant addresses, formatting errors in form builder responses, and difficulties displaying candidate-submitted resumes. Most of these issues have been resolved, and our team is continuing to address any remaining concerns. We appreciate your patience and understanding as we ensure everything functions as expected.
Posted Jan 28, 2025 - 09:48 PST
This incident affected: Application Viewer.