Some Users May be Experiencing Delays

Incident Report for Applicant Tracking Software

Postmortem

Incident Summary: On March 5th, from 8:20 AM to 2:50 PM Pacific Time, our system experienced a temporary delay in background processes due to an unexpected surge in custom field update requests. 

Customer Impact: Some background processes (such as messages to applicants, integration data transfers, and reporting) in the ATS ran more slowly than usual during this period. While all tasks were successfully processed, users may have noticed temporary delays in system performance.

Root Cause: A higher-than-normal volume of custom field update requests temporarily impacted the efficiency of our background processing system. As these tasks were prioritized, other background functions experienced delays.

Resolution Steps:

  • Our team quickly identified the issue and worked to adjust job prioritization to restore normal system performance.
  • We adjusted the priority of these processes to free up system resources and restore normal processing times.

Preventative Measures:

  • We have implemented safeguards to balance system load and prevent similar delays in the future.
  • Ongoing monitoring will continue to enhance system responsiveness.

We appreciate your patience and understanding. If you have any questions, please don’t hesitate to contact our support team.

Posted Mar 06, 2025 - 14:06 PST

Resolved

We are pleased to inform you that a fix has been implemented, monitored, and is now proving to hold its own in the code. Our team of tech wizards is confident that background job processing in the ATS is now functioning as expected.

If you are still experiencing any issues with delayed background jobs, please try clearing your cache and cookies before reaching out to support. This will help to ensure that you are viewing the most up-to-date version of the Applicant Tracking System.

We sincerely apologize for any inconvenience this issue may have caused, and we appreciate your patience and understanding as we worked to resolve it.
Posted Mar 05, 2025 - 14:56 PST

Update

We wanted to provide an update on the background job processing delays in the ATS.

Our team identified that password resets were also being impacted. We have since deployed an update to resolve this issue and are actively monitoring its progress.

We anticipate that normal processing times will be fully restored in approximately 2.5 hours.

Thank you for your continued patience and trust as we work to resolve this!
Posted Mar 05, 2025 - 14:00 PST

Identified

We've identified a temporary technical issue, which is causing slight delays with background job processing in the ATS. We understand the importance of keeping things running smoothly, and we sincerely apologize for any inconvenience this may cause.

Here's what we know: Background jobs—including candidate notifications, integrations, and reports—are experiencing delays. Password resets do not appear to be impacted at this time.

What we're doing: Our team of tech wizards is diligently investigating the issue and scaling up resources to process the backlog as quickly as possible.

What you can do: At this time, no action is required on your end. Background jobs will continue to process, just at a slower pace than usual.

We'll keep you updated as we progress in our efforts to restore normal processing times. Thank you for your patience and trust!
Posted Mar 05, 2025 - 11:23 PST
This incident affected: Application Viewer, Messages, and Offer Letters.