2FA is currently Unavailable
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 17:56 PDT
Identified
At this time, some users may experience issues with 2fA features on the account. We're investigating into this and will follow up. We do apologize for any inconvenience this has caused
Posted Apr 28, 2021 - 11:44 PDT