Some users might encounter the lack of the "End Campaign" button on currently active daily job board postings.
Incident Report for Applicant Tracking Software
Resolved
We're excited to share that this issue has been successfully resolved. Thank you for your patience, and if you encounter any further issues or have questions, feel free to reach out to our support team.
Posted Dec 07, 2023 - 11:00 PST
Identified
We're aware that some users are facing the absence of the "End Campaign" button on active daily job board postings. If you need to cancel a daily placement and are unable to do so, please contact our support team for assistance. We appreciate your patience as we work to resolve this issue promptly. Thank you for your understanding!
Posted Dec 06, 2023 - 11:16 PST
This incident affected: Job Board Distribution.