Service Disruption
Incident Report for Applicant Tracking Software
Resolved
The incident has been resolved and all services restored. We apologize for any inconvenience that this has caused.
Posted Dec 22, 2022 - 09:44 PST
Investigating
We are currently experiencing a service disruption. Our Engineering team is working to identify the root cause and implement a solution as quickly as possible. We apologize for any inconvenience that this may cause.
Posted Dec 22, 2022 - 09:15 PST
This incident affected: Account Access.