Some users may experience a delay in search indexing new applications.
Incident Report for Applicant Tracking Software
Resolved
This has been resolved and we're back to normal processing times.
Posted Dec 15, 2021 - 13:53 PST
Investigating
We are experiencing a delay in search indexing new applications. There may be a delay for applications submitted in the past hour appearing in search results or certain filters. No data has been lost and the system is fully operational. Currently, the average delay is approximately 20 minutes.
Posted Dec 15, 2021 - 13:41 PST
This incident affected: Application Viewer.