Password Reset & New User Account Creation are Currently Not Available for Some Users
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Nov 03, 2020 - 13:02 PST
Identified
Some users may experience issues with account creation or password recovery options, we are working on resolving this issue as soon as possible and sincerely apologize for any inconvenience this has caused.
Posted Nov 03, 2020 - 11:58 PST