We’re receiving reports of some job postings failing. We’re on the case and will provide another update once we have more details to share. We’re sorry for the inconvenience.
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 14:25 PDT
Update
We are continuing to monitor for any further issues.
Posted Mar 21, 2024 - 09:03 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2024 - 14:55 PDT
Update
We are continuing to investigate this issue.
Posted Mar 20, 2024 - 12:56 PDT
Investigating
We are currently investigating this issue.
Posted Mar 20, 2024 - 11:25 PDT
This incident affected: Job Board Distribution.