Some users may not be able to view some elements of the Applicant Reports page
Incident Report for Applicant Tracking Software
Resolved
The Applicant reports page functionality has been restored. If you are still experiencing any issues or have further concerns, please don't hesitate to contact our support team for personalized assistance. We appreciate your patience and understanding throughout this resolution process.
Posted Jan 25, 2024 - 09:32 PST
Update
Our team continues work on the ongoing issue with the Applicant Reports page. We understand the importance of this matter and are committed to resolving it as quickly as possible. Thank you for your patience.
Posted Jan 24, 2024 - 08:29 PST
Investigating
We're currently in the midst of investigating an issue with the Applicant Reports page. Our dedicated team is on the case, diligently searching for the root cause. Your understanding and patience are greatly appreciated as we work to ensure all data is visible.
Posted Jan 22, 2024 - 16:58 PST
This incident affected: Reports.