Recruitment Activity Report
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 25, 2019 - 14:29 PST
Investigating
Some users have reported issues with the Recruitment Activity Report appearing blank. Further updates will be provided as the investigation continues.
Posted 8 months ago. Jan 24, 2019 - 13:56 PST