Some Users May Experience Intermittent Messaging Delays with Certain Email Providers
Incident Report for Applicant Tracking Software
Postmortem

Incident Summary: From January 7, 2025, at 3:30 PM PT to January 10, 2025, at 2:40 PM PT, emails sent from our Applicant Tracking System (ATS) to Microsoft email domains (Outlook, Hotmail, Live, and MSN) experienced significant delays or failed deliveries. This issue was caused by challenges related to Microsoft’s email filtering policies.

Customer Impact: During this time, applicants with Microsoft-related email addresses were not receiving email notifications sent through our ATS. This disruption may have delayed communication between hiring managers and candidates. Users were advised to use alternative communication methods to reach candidates.

Root Cause: The delays and delivery failures occurred due to blocks and throttling applied by Microsoft’s email filtering systems, which affected our ability to deliver messages reliably.

Resolution Steps:

  • Our team identified the issue and worked with our email provider to address the blocks and throttling.
  • By January 10, 2025, at 2:40 PM PT, normal email delivery was fully restored.

Moving Forward: To prevent similar incidents, we are:

  • Partnering with email deliverability experts to monitor and improve our processes.
  • Enhancing monitoring tools to identify potential email issues earlier.
  • Continuing collaboration with Microsoft to align with their email filtering policies and ensure reliable delivery.

If you have any questions or concerns, please contact our support team. We appreciate your patience and understanding as we continue to improve our services.

Posted Jan 16, 2025 - 13:34 PST

Resolved
We are pleased to share that a fix has been successfully implemented and monitored, and the system is now functioning as expected.

If you continue to experience issues with delayed messages, please contact our support team. To assist us in investigating further, include the email address of the applicant you are trying to reach in your support request.

We sincerely apologize for any inconvenience this issue may have caused and thank you for your patience and understanding as we worked toward a resolution.
Posted Jan 10, 2025 - 16:25 PST
Identified
We are currently experiencing intermittent messaging delays with the following email service providers: Outlook, Hotmail, Live, and MSN. This issue is affecting some users, and we are actively working with these email providers to resolve it as quickly as possible.

Additionally, we observed some permanent failures with messages to these providers starting on January 7, 2025. However, the current impact appears to be limited to delays.

Recommended Actions:

To avoid potential disruptions, we recommend using alternative communication methods, such as other email addresses or phone calls, to contact your candidates.

We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding as we work to address the issue.
Posted Jan 10, 2025 - 10:21 PST
This incident affected: Messages.