Messages May Be Delayed

Incident Report for Applicant Tracking Software

Resolved

This incident has been resolved.
Posted Oct 26, 2024 - 10:56 PDT

Identified

Our third-party email service provider is currently experiencing issues with email delivery.

Here's what we know so far:

-Messaging delays are occurring.
-The issue is affecting all users.

In the meantime, should your message be urgent, please use alternative communication channels, such as email or phone calls, to communicate with your candidates.

We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Oct 25, 2024 - 09:01 PDT
This incident affected: Messages.