Issues when sending offer letters and documents
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Feb 08, 2021 - 16:17 PST
Investigating
Some users may experience issues when sending offer letters and documents. Our Vendor has identified the issue and a fix is being deployed. We will follow up with additional updates when we receive them. We apologize for any inconvenience this may cause.
Posted Feb 08, 2021 - 14:30 PST
This incident affected: Offer Letters.