Some Users May be Experiencing Temporary Outages or Delays

Incident Report for Applicant Tracking Software

Postmortem

Summary

On December 9, 2025, some users experienced brief periods where the Applicant Tracking System was temporarily unavailable. As a result, the system displayed our maintenance page during these moments.

Our team identified the cause quickly and deployed a fix the same morning. System performance has been stable since, and we’ve continued to monitor closely to ensure everything remains healthy.

What Happened

A routine update introduced a database query that took longer to run than expected. This caused our application servers to pause while waiting for the query to complete, which briefly interrupted normal system operation.

Once the issue was identified, our engineers deployed an improvement to optimize that database query, which restored normal response times and resolved the issue.

Customer Impact

During the affected periods, users were unable to access the platform or use any UI or API features. All services returned to normal once the fix was applied.

Resolution

Our team implemented an update that improved the performance of the affected query. After deploying this change, the system recovered immediately and remained stable.

What We’re Doing Moving Forward

We’re taking several steps to prevent similar issues in the future, including strengthening safeguards that detect slow-running queries earlier.

We’re committed to providing a reliable, seamless experience, and we truly appreciate your patience and trust. If you experience any lingering issues or have questions, please reach out to our support team - we’re always here to help.

Posted Dec 11, 2025 - 11:29 PST

Resolved

The technical issue causing intermittent outages has been fully resolved. Our engineering team identified the root cause and implemented a fix, and system functionality has returned to normal.

We’ll continue monitoring performance closely to ensure everything remains stable.

Thank you for your patience while we worked through this. We truly appreciate your understanding and trust as we aim to provide a reliable and seamless experience in the Applicant Tracking System.

If you have any lingering issues or questions, feel free to reach out to our support team—we’re here to help!
Posted Dec 09, 2025 - 13:36 PST

Identified

We've identified a temporary technical issue, which is causing intermittent outages, and an engineer is already actively working on a fix.

We understand the importance of access and we sincerely apologize for any inconvenience this may cause.

What we're doing: Our team of tech wizards is diligently investigating the issue and working tirelessly to resolve it promptly.
What you can do: Sit back, relax, and enjoy a refreshing cup of applicant tracking system-themed tea. We'll handle the rest! You can rest assured that this remains our top priority.

We'll keep you updated as we progress in our endeavors to restore the Applicant Tracking System to its full functionality. Thank you for your continued patience and trust!
Posted Dec 09, 2025 - 11:25 PST
This incident affected: Account Access, Account Details, Application Viewer, Background/Drug Screening, Bulk Actions, Calendar, Careers Page, Create/Edit Jobs, Help, Job Board Distribution, Job Filtering, Messages, Offer Letters, Reports, Third Party Services, and Workflows.