Some applicants may be unable to sign an offer letter.
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 09:12 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 21, 2020 - 09:04 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 21, 2020 - 09:04 PDT
Investigating
We are currently investigating the issue.
Posted Jul 21, 2020 - 08:07 PDT
This incident affected: Offer letters.