Delay in Processing Background Checks
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Nov 01, 2019 - 12:28 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 01, 2019 - 12:20 PDT
Investigating
Some users may be impacted by a delay in the processing of background checks. There may be a delay in ordering/sending them out. Our sincerest apologies for any inconvenience this has caused.
Posted Nov 01, 2019 - 11:11 PDT
This incident affected: Background checks.