Some users may experience delays in messages, offer letters, Reports, and Activity Log entries

Incident Report for Applicant Tracking Software

Resolved

This incident has been resolved. The background job processing backlog has been cleared, and messages, offer letters, and Activity Log entries should now be delivering and appearing as expected.

We apologize for any inconvenience this may have caused and appreciate your patience while our team worked through the queue. If you continue to experience any issues, please don't hesitate to reach out to our support team.
Posted Jun 09, 2026 - 13:33 PDT

Investigating

We are currently investigating a delay in background job processing that is causing outbound messages, offer letters, reports, and Activity Log entries to be slow to appear or deliver. Our engineering team is actively working to resolve the backlog.

While we work through this, we kindly ask that users refrain from resubmitting reports, resending messages, or resending offer letters, as additional submissions may extend the delay for all users.

We will provide updates as the situation progresses. At this time, the estimated recovery window is approximately four hours.
Posted Jun 09, 2026 - 10:48 PDT
This incident affected: Application Viewer, Messages, Offer Letters, and Reports.