The ATS platform is currently unavailable
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Dec 10, 2021 - 14:02 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 10, 2021 - 13:58 PST
Investigating
We are currently investigating the issue.
Posted Dec 10, 2021 - 13:51 PST
This incident affected: Careers page, Offer letters, Message templates, Form builder, Background checks, Help, Account Login, and Applications.