Some Users May Be Experiencing Candidate Street Address Not Saving

Incident Report for Applicant Tracking Software

Resolved

The issue affecting candidate street addresses not saving has been resolved. Our team identified the cause and implemented a fix, and addresses should now save as expected.
Posted Mar 06, 2026 - 14:22 PST

Investigating

We’re currently investigating reports that some users may be experiencing issues with candidate street addresses not saving properly. Our team is actively working to identify the cause and address it as quickly as possible.
Posted Mar 06, 2026 - 14:05 PST
This incident affected: Application Viewer.