Search All Applicants Feature
Incident Report for Applicant Tracking Software
Resolved
We have resolved the issue with the Search All Applicants feature. Thank you for your patience.
Posted 5 days ago. Feb 11, 2019 - 17:06 PST
Investigating
Some clients have reported that the Search All Applicants feature is not working. We are currently looking into the issue.
Posted 5 days ago. Feb 11, 2019 - 16:09 PST